Yoast SEO 20.5 不再支持 PHP 5.6、7.0 和 7.1

Yoast SEO 20.5于本周发布,其中包含多项安全修复和改进的 Google SERP 预览。预览显示了具有 Google 当前样式的移动和桌面片段,因此用户可以准确地看到他们的片段的外观并调整他们如何针对 Google 搜索结果优化它们。

此版本的另一个亮点是 Yoast SEO 降低了与 PHP 5.6、7.0 和 7.1 的兼容性。该插件现在需要 PHP 7.2.5 或更高版本(以及 WP 6.0)。虽然乍一看这似乎很极端,但大约 89.9% 的 WordPress 网站都在 PHP 7.2+ 上运行。WordPress 不会将这些统计信息与 WP 版本号进行交叉引用,但运行在更旧版本 WordPress 上的网站可能也在不受支持的 PHP 版本上运行。

WordPress PHP 版本统计– 2023 年 4 月 11 日

让 WordPress 网站更新到最新版本的 PHP 是一个缓慢的过程,但从历史上看,Yoast SEO 一直是推动用户升级其 PHP 版本的变革力量。在 2017 年发布的 4.5 版中,Yoast SEO 将其估计的 650 万用户群推向推动主机将其客户升级到 PHP 7 的运动。那个版本的插件引入了一个大的、不可关闭的通知,敦促站点管理员升级到 PHP 7。

“为了推动网络向前发展,我们需要反对旧的、缓慢的和不安全的软件,”Yoast 创始人 Joost de Valk 当时说。“因为网络主机没有升级 PHP,我们决定开始从插件内部推动这一点。” 他认为 WordPress 生态系统正在失去优秀的开发人员,因为该项目进展太慢,并且还需要安全性和速度。

尽管最新版本 20.5 将与大约 10% 运行不受支持的 PHP 版本的 WordPress 网站不兼容,但这一进展对于维护健康和安全的生态系统是必要的。

发表回复

您的电子邮箱地址不会被公开。 必填项已用 * 标注